<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://www.sswug.org/xmlrpc.php"><link media="all" href="https://www.sswug.org/wp-content/cache/autoptimize/css/autoptimize_ee4ef62f6706d7b4319bfd00a1df9468.css" rel="stylesheet" /><link media="screen" href="https://www.sswug.org/wp-content/cache/autoptimize/css/autoptimize_67dcd357d1d4674a59afb5128994bd43.css" rel="stylesheet" /><style media="print">@media print{.pmpro_a-print{display:none;position:absolute;left:-9999px}}</style><title>Worker Service in .NET Core 3.1 - SSWUG.ORG</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Worker Service in .NET Core 3.1 - SSWUG.ORG" /><meta property="og:description" content="(Shahed C) This is the twenty-third of a new series of posts on ASP .NET Core 3.1 for 2020. In this series, we’ll cover 26 topics over a span of 26 weeks from January through June 2020, titled ASP .NET Core A-Z!" /><meta property="og:url" content="https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/" /><meta property="og:site_name" content="SSWUG.ORG" /><meta property="article:publisher" content="https://www.facebook.com/SSWUG" /><meta property="article:published_time" content="2020-07-30T07:00:26+00:00" /><meta property="article:modified_time" content="2020-07-30T07:00:00+00:00" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@SSWUGORG" /><meta name="twitter:site" content="@SSWUGORG" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.sswug.org/#website","url":"https://www.sswug.org/","name":"SSWUG.ORG","description":"SQL Server, Azure SQL Database, Amazon RDS &amp; AWS, Oracle and IBM Help","potentialAction":[{"@type":"SearchAction","target":"https://www.sswug.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/#webpage","url":"https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/","name":"Worker Service in .NET Core 3.1 - SSWUG.ORG","isPartOf":{"@id":"https://www.sswug.org/#website"},"datePublished":"2020-07-30T07:00:26+00:00","dateModified":"2020-07-30T07:00:00+00:00","author":{"@id":"https://www.sswug.org/#/schema/person/ec72d555f13eba6f1acc5cf844bb9d43"},"breadcrumb":{"@id":"https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/"]}]},{"@type":"BreadcrumbList","@id":"https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.sswug.org/","url":"https://www.sswug.org/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/","url":"https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/","name":"Worker Service in .NET Core 3.1"}}]},{"@type":["Person"],"@id":"https://www.sswug.org/#/schema/person/ec72d555f13eba6f1acc5cf844bb9d43","name":"SSWUG Research","image":{"@type":"ImageObject","@id":"https://www.sswug.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/a870a712779d9f71ceb4ccc58d3cc617?s=96&d=mm&r=g","caption":"SSWUG Research"},"description":"SSWUG Research is the team that brings you SSWUG-based content and community links. Have an idea? Send us a note at sswugresearch@bitsonthewire.com - we'd love to hear from you."}]}</script>  <script type='text/javascript'>console.log('PixelYourSite Free version 7.1.7');</script> <link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="SSWUG.ORG &raquo; Feed" href="https://www.sswug.org/feed/" /><link rel="alternate" type="application/rss+xml" title="SSWUG.ORG &raquo; Comments Feed" href="https://www.sswug.org/comments/feed/" /><link rel="alternate" type="text/calendar" title="SSWUG.ORG &raquo; iCal Feed" href="https://www.sswug.org/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="SSWUG.ORG &raquo; Worker Service in .NET Core 3.1 Comments Feed" href="https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sswug.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.4"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='dashicons-css'  href='https://www.sswug.org/wp-includes/css/dashicons.min.css?ver=5.3.4' type='text/css' media='all' /><style id='wp-image-borders-styles-inline-css' type='text/css'>.wp-image-borders .alignright,
		.wp-image-borders .alignleft,
		.wp-image-borders .aligncenter,
		.wp-image-borders .alignnone,
		.wp-image-borders .size-auto,
		.wp-image-borders .size-full,
		.wp-image-borders .size-large,
		.wp-image-borders .size-medium,
		.wp-image-borders .size-thumbnail,
		.wp-image-borders .alignright img,
		.wp-image-borders .alignleft img,
		.wp-image-borders .aligncenter img,
		.wp-image-borders .alignnone img,
		.wp-image-borders .size-auto img,
		.wp-image-borders .size-full img,
		.wp-image-borders .size-large img,
		.wp-image-borders .size-medium img,
		.wp-image-borders .size-thumbnail img {
	   border-style: solid !important;
	   border-width: 1px !important;
	   border-radius: 1px !important;
	   border-color: #383838 !important;
	   -moz-box-shadow: 0px 0px 0px 0px #afafaf !important;
	   -webkit-box-shadow: 0px 0px 0px 0px #afafaf !important;
	   box-shadow: 0px 0px 0px 0px #afafaf !important;
   }</style><link rel='stylesheet' id='tribune-google-fonts-css'  href='//fonts.googleapis.com/css?family=Merriweather%3Aregular%2C700%2C700i%2Citalic%7CPlayfair+Display%3Aregular%2C700%7CMontserrat%3Aregular%2C700%7CRoboto+Condensed%3Aregular%2C700&#038;ver=5.3.4' type='text/css' media='all' /><link rel='stylesheet' id='tribune-google-font-default-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7CPlayfair+Display%3A400%2C700%7CRoboto+Condensed%3A400%2C700%7CMerriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic&#038;subset=latin%2Cgreek%2Ccyrillic&#038;ver=5.3.4' type='text/css' media='all' /> <script type='text/javascript'>var cnArgs = {"ajaxUrl":"https:\/\/www.sswug.org\/wp-admin\/admin-ajax.php","nonce":"e14a391f2c","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"0","cache":"0","refuse":"0","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"1","coronabarActive":"0"};</script> <script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/12/jwplayer.js?ver=5.3.4'></script> <script type='text/javascript'>var pysOptions = {"staticEvents":{"facebook":{"PageView":[{"params":[],"delay":0,"ids":[]}],"GeneralEvent":[{"params":{"post_type":"post","post_id":"275997","content_name":"Worker Service in .NET Core 3.1","categories":"Community","tags":"Development"},"delay":0,"ids":[]}]}},"dynamicEventsParams":[],"dynamicEventsTriggers":[],"facebook":{"pixelIds":["252348685283892"],"advancedMatching":[],"removeMetadata":false,"contentParams":{"post_type":"post","post_id":275997,"content_name":"Worker Service in .NET Core 3.1","categories":"Community","tags":"Development"},"commentEventEnabled":true,"wooVariableAsSimple":false,"downloadEnabled":true,"formEventEnabled":true},"debug":"","siteUrl":"https:\/\/www.sswug.org","ajaxUrl":"https:\/\/www.sswug.org\/wp-admin\/admin-ajax.php","commonEventParams":{"domain":"\/www.sswug.org","user_roles":"guest","plugin":"PixelYourSite"},"commentEventEnabled":"1","downloadEventEnabled":"1","downloadExtensions":["doc","exe","js","pdf","ppt","tgz","zip","xls"],"formEventEnabled":"1","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":false,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":null,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":null,"cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","ginger_integration_enabled":false,"cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false},"woo":{"enabled":false,"addToCartOnButtonEnabled":false,"addToCartOnButtonValueEnabled":false,"addToCartOnButtonValueOption":"price","removeFromCartEnabled":true,"removeFromCartSelector":".cart .product-remove .remove"},"edd":{"enabled":false,"addToCartOnButtonEnabled":false,"addToCartOnButtonValueEnabled":false,"addToCartOnButtonValueOption":"price","removeFromCartEnabled":true}};</script> <link rel='https://api.w.org/' href='https://www.sswug.org/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sswug.org/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sswug.org/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.sswug.org/?p=275997' /><link rel="alternate" type="application/json+oembed" href="https://www.sswug.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sswug.org%2Fsswugresearch%2Fcommunity%2Fworker-service-in-net-core-3-1%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.sswug.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sswug.org%2Fsswugresearch%2Fcommunity%2Fworker-service-in-net-core-3-1%2F&#038;format=xml" /> <script type="text/javascript">jwplayer.key='wzJCN7+7VY5JsZZ8qAwstqzKkDxqb5Xtdk+zp8Q1cgk=';jwplayer.defaults = { "ph": 2 };</script> <script type="text/javascript">if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }</script> <meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.sswug.org"><link rel="https://theeventscalendar.com/" href="https://www.sswug.org/wp-json/tribe/events/v1/" /><meta name="generator" content="Tribune 4.2.2" /><meta name="generator" content="WPZOOM Framework 1.9.0" /> <script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script> <style type="text/css" id="tribune-custom-css">.navbar-brand .tagline{display:none;}.sb-search{display:none;}.main-navbar{background:#3d3d3d;}.main-navbar #navbar-main a:hover{color:#f75636;}#footer{background-color:#0a0000;}</style><style type="text/css"></style><style type="text/css">.synved-social-resolution-single {
display: inline-block;
}
.synved-social-resolution-normal {
display: inline-block;
}
.synved-social-resolution-hidef {
display: none;
}

@media only screen and (min--moz-device-pixel-ratio: 2),
only screen and (-o-min-device-pixel-ratio: 2/1),
only screen and (-webkit-min-device-pixel-ratio: 2),
only screen and (min-device-pixel-ratio: 2),
only screen and (min-resolution: 2dppx),
only screen and (min-resolution: 192dpi) {
	.synved-social-resolution-normal {
	display: none;
	}
	.synved-social-resolution-hidef {
	display: inline-block;
	}
}</style><style type="text/css" id="custom-background-css">body.custom-background { background-color: #d6d6d6; }</style> <script src="https://www.sswug.org/wp-content/cache/autoptimize/js/autoptimize_9d2d7f9bd4c404a60949687290537c14.js"></script></head><body class="post-template-default single single-post postid-275997 single-format-standard custom-background wp-custom-logo cookies-not-set pmpro-body-has-access tribe-no-js elementor-default"><div class="site-wrap"><div class="page-wrap"><header id="header"><nav class="navbar" role="navigation"><nav class="top-navbar" role="navigation"><div class="header_social"><div id="search-5" class="widget widget_search"><form method="get" id="searchform" action="https://www.sswug.org/"> <input type="search" class="sb-search-input" placeholder="Enter your keywords..."  name="s" id="s" /> <input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" /> <span class="sb-icon-search"></span></form><div class="clear"></div></div></div><div class="navbar-header"> <a class="navbar-toggle" href="#menu-top-slide"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </a><div id="menu-top-slide" class="menu-member-options-menu-container"><ul id="menu-member-options-menu" class="menu"><li id="menu-item-252522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252522"><a href="/wp-login.php">Login</a></li><li id="menu-item-143422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-143422"><a href="https://www.sswug.org/membership-account/">Join / Your Account</a><ul class="sub-menu"><li id="menu-item-252523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252523"><a href="http://bitonthewire.wpengine.com/wp-login.php">Login</a></li><li id="menu-item-143424" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143424"><a href="/membership-options-19/">Register</a></li><li id="menu-item-256230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256230"><a href="/membership-options-19/">Membership Levels</a></li><li id="menu-item-236145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236145"><a href="/membership-account/">My Membership</a></li></ul></li><li id="menu-item-143440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143440"><a href="https://www.sswug.org/about-sswug-org/">Why Join?</a></li><li id="menu-item-143437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143437"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li></ul></div></div><div id="navbar-top"><div class="menu-member-options-menu-container"><ul id="menu-member-options-menu-1" class="nav navbar-nav dropdown sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252522"><a href="/wp-login.php">Login</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-143422"><a href="https://www.sswug.org/membership-account/">Join / Your Account</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252523"><a href="http://bitonthewire.wpengine.com/wp-login.php">Login</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143424"><a href="/membership-options-19/">Register</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256230"><a href="/membership-options-19/">Membership Levels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236145"><a href="/membership-account/">My Membership</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143440"><a href="https://www.sswug.org/about-sswug-org/">Why Join?</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143437"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li></ul></div></div></nav><div class="clear"></div></nav><div id="header-inner"><div class="navbar-brand left-align"> <a href="https://www.sswug.org/" class="custom-logo-link" rel="home" itemprop="url"><img width="600" height="184" src="https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-600x184.png" class="custom-logo" alt="SSWUG.ORG" itemprop="logo" srcset="https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo.png 600w, https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-300x92.png 300w, https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-179x55.png 179w, https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-431x132.png 431w" sizes="(max-width: 600px) 100vw, 600px" /></a> <span class="tagline">SQL Server, Azure SQL Database, Amazon RDS &amp; AWS, Oracle and IBM Help</span> <span class="header_date">Thursday, July 30, 2020</span></div><div id="head_banner"> <span style="font-size:12px;"><b>An online community of DBAs, developers and data intelligence builders,</b> with videos, articles, resources and online<Br> events for members and non-members.    <a href="/membership-options-19/"><b>Find out more</a> >></b></span></div><div class="clear"></div></div><nav class="navbar" role="navigation"><nav class="main-navbar" role="navigation"><div id="sb-search" class="sb-search"><form method="get" id="searchform" action="https://www.sswug.org/"> <input type="search" class="sb-search-input" placeholder="Enter your keywords..."  name="s" id="s" /> <input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" /> <span class="sb-icon-search"></span></form></div><div class="navbar-header"> <a class="navbar-toggle" href="#menu-main-slide"> <span class="toggle-bars"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </span> <span class="toggle-text">Menu</span> </a><div id="menu-main-slide" class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-143371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143371"><a href="/">Home</a></li><li id="menu-item-2435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2435"><a>Content Areas</a><ul class="sub-menu"><li id="menu-item-72833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72833"><a href="/">Regular Contributors</a><ul class="sub-menu"><li id="menu-item-72838" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72838"><a href="/author/alexanderchigrik/">Alexander Chigrik</a></li><li id="menu-item-72836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72836"><a href="/?s=kevin+kline">Kevin Kline</a></li><li id="menu-item-72834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72834"><a href="/author/laurarose/">Laura Rose</a></li><li id="menu-item-72835" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72835"><a href="/author/swynk/">Stephen Wynkoop</a></li></ul></li><li id="menu-item-2433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2433"><a href="https://www.sswug.org/category/development/">Development</a></li><li id="menu-item-252514" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252514"><a href="/tag/IBM">IBM</a></li><li id="menu-item-252515" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252515"><a href="/tag/json-java-xml/">JSON/JAVA/XML</a></li><li id="menu-item-252516" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252516"><a href="/tag/open-source">Open Source</a></li><li id="menu-item-252517" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252517"><a href="/tag/SQL-Server">SQL Server</a></li><li id="menu-item-252518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252518"><a href="/tag/oracle">Oracle</a></li><li id="menu-item-252519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252519"><a href="/tag/sharepoint-bi/">Sharepoint/BI</a></li><li id="menu-item-251907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251907"><a href="/?s=(script%20library)">Script Library</a></li></ul></li><li id="menu-item-143494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143494"><a>Video</a><ul class="sub-menu"><li id="menu-item-236121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236121"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li id="menu-item-72840" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72840"><a href="/?s=sswugtv%20kevin%20kline">Kevin Kline Briefings</a></li><li id="menu-item-72839" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72839"><a href="/?s=laura+rose">Laura Rose Coaching Series</a></li><li id="menu-item-143495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143495"><a href="/?s=sswugtv">SSWUGtv Shows</a></li></ul></li><li id="menu-item-143456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143456"><a href="/events/">Online Events</a><ul class="sub-menu"><li id="menu-item-236119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236119"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li id="menu-item-236120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236120"><a href="/events/">Upcoming Events</a></li></ul></li><li id="menu-item-2430" class="b menu-item menu-item-type-custom menu-item-object-custom menu-item-2430"><a target="_blank" rel="noopener noreferrer" href="http://careers.sswug.org">Job Board</a></li><li id="menu-item-244968" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-244968"><a href="https://www.sswug.org/what-is-a-pro-membership/">Pro Members</a><ul class="sub-menu"><li id="menu-item-244971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244971"><a href="https://www.sswug.org/what-is-a-pro-membership/">About Pro Membership</a></li><li id="menu-item-244970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244970"><a href="https://www.sswug.org/video-categories-and-options/">Video Categories</a></li><li id="menu-item-244972" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-244972"><a href="https://www.sswug.org/tag/pro-video/">Video Selections</a></li><li id="menu-item-244988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244988"><a href="https://www.sswug.org/category/class-info/">Online Classes</a></li></ul></li><li id="menu-item-71898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-71898"><a href="/">About SSWUG.org</a><ul class="sub-menu"><li id="menu-item-71899" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71899"><a href="https://www.sswug.org/about-sswug-org/">About SSWUG.org</a></li><li id="menu-item-72821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-72821"><a href="https://www.sswug.org/submit-an-article-to-sswug-org/">Write for SSWUG</a><ul class="sub-menu"><li id="menu-item-72831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72831"><a href="https://www.sswug.org/about-writing-for-sswug/">About Writing for SSWUG</a></li></ul></li><li id="menu-item-72828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72828"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li><li id="menu-item-143506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143506"><a href="https://www.sswug.org/privacy-statement-for-sswug-orgthe-sql-server-worldwide-users-group/">Privacy Statement</a></li><li id="menu-item-143501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143501"><a href="https://www.sswug.org/terms-of-service-2/">Terms of Service.</a></li><li id="menu-item-72825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72825"><a href="https://www.sswug.org/advertising-options/">Advertising Options</a></li></ul></li></ul></div></div><div id="navbar-main"><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="nav navbar-nav dropdown sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143371"><a href="/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2435"><a>Content Areas</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72833"><a href="/">Regular Contributors</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72838"><a href="/author/alexanderchigrik/">Alexander Chigrik</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72836"><a href="/?s=kevin+kline">Kevin Kline</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72834"><a href="/author/laurarose/">Laura Rose</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72835"><a href="/author/swynk/">Stephen Wynkoop</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2433"><a href="https://www.sswug.org/category/development/">Development</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252514"><a href="/tag/IBM">IBM</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252515"><a href="/tag/json-java-xml/">JSON/JAVA/XML</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252516"><a href="/tag/open-source">Open Source</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252517"><a href="/tag/SQL-Server">SQL Server</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252518"><a href="/tag/oracle">Oracle</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252519"><a href="/tag/sharepoint-bi/">Sharepoint/BI</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251907"><a href="/?s=(script%20library)">Script Library</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143494"><a>Video</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236121"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72840"><a href="/?s=sswugtv%20kevin%20kline">Kevin Kline Briefings</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72839"><a href="/?s=laura+rose">Laura Rose Coaching Series</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143495"><a href="/?s=sswugtv">SSWUGtv Shows</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143456"><a href="/events/">Online Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236119"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236120"><a href="/events/">Upcoming Events</a></li></ul></li><li class="b menu-item menu-item-type-custom menu-item-object-custom menu-item-2430"><a target="_blank" rel="noopener noreferrer" href="http://careers.sswug.org">Job Board</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-244968"><a href="https://www.sswug.org/what-is-a-pro-membership/">Pro Members</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244971"><a href="https://www.sswug.org/what-is-a-pro-membership/">About Pro Membership</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244970"><a href="https://www.sswug.org/video-categories-and-options/">Video Categories</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-244972"><a href="https://www.sswug.org/tag/pro-video/">Video Selections</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244988"><a href="https://www.sswug.org/category/class-info/">Online Classes</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-71898"><a href="/">About SSWUG.org</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71899"><a href="https://www.sswug.org/about-sswug-org/">About SSWUG.org</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-72821"><a href="https://www.sswug.org/submit-an-article-to-sswug-org/">Write for SSWUG</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72831"><a href="https://www.sswug.org/about-writing-for-sswug/">About Writing for SSWUG</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72828"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143506"><a href="https://www.sswug.org/privacy-statement-for-sswug-orgthe-sql-server-worldwide-users-group/">Privacy Statement</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143501"><a href="https://www.sswug.org/terms-of-service-2/">Terms of Service.</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72825"><a href="https://www.sswug.org/advertising-options/">Advertising Options</a></li></ul></li></ul></div></div><div class="clear"></div></nav></nav><div class="clear"></div></header><main id="main" role="main"><div class="content-area"><article id="post-275997" class="post-275997 post type-post status-publish format-standard category-community tag-development pmpro-has-access"><header class="entry-header"> <span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h1 class="entry-title">Worker Service in .NET Core 3.1</h1><div class="post-meta"> <span class="entry-author vcard author">by <a class="url fn n" href="https://www.sswug.org/author/sswugresearch/">SSWUG Research</a></span></div></header><div class="clear"></div><div class="entry-content"><p>(Shahed C) This is the twenty-third of a new series of posts on ASP .NET Core 3.1 for 2020. In this series, we’ll cover 26 topics over a span of 26 weeks from January through June 2020, titled ASP .NET Core A-Z!</p><p><br /> <a href="https://www.sswug.org/standard-member-info"><button>Register to Read</button></a><br /> <br /></p> <a class="synved-social-button synved-social-button-share synved-social-size-24 synved-social-resolution-single synved-social-provider-facebook nolightbox" data-provider="facebook" target="_blank" rel="nofollow" title="Share on Facebook" href="http://www.facebook.com/sharer.php?u=https%3A%2F%2Fwww.sswug.org%2F%3Fp%3D275997&#038;t=Worker%20Service%20in%20.NET%20Core%203.1&#038;s=100&#038;p&#091;url&#093;=https%3A%2F%2Fwww.sswug.org%2F%3Fp%3D275997&#038;p&#091;images&#093;&#091;0&#093;=&#038;p&#091;title&#093;=Worker%20Service%20in%20.NET%20Core%203.1" style="font-size: 0px; width:24px;height:24px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="Facebook" title="Share on Facebook" class="synved-share-image synved-social-image synved-social-image-share" width="24" height="24" style="display: inline; width:24px;height:24px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.sswug.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/48x48/facebook.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-24 synved-social-resolution-single synved-social-provider-twitter nolightbox" data-provider="twitter" target="_blank" rel="nofollow" title="Share on Twitter" href="https://twitter.com/intent/tweet?url=https%3A%2F%2Fwww.sswug.org%2F%3Fp%3D275997&#038;text=Hey%20check%20this%20out" style="font-size: 0px; width:24px;height:24px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="twitter" title="Share on Twitter" class="synved-share-image synved-social-image synved-social-image-share" width="24" height="24" style="display: inline; width:24px;height:24px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.sswug.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/48x48/twitter.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-24 synved-social-resolution-single synved-social-provider-reddit nolightbox" data-provider="reddit" target="_blank" rel="nofollow" title="Share on Reddit" href="http://www.reddit.com/submit?url=https%3A%2F%2Fwww.sswug.org%2F%3Fp%3D275997&#038;title=Worker%20Service%20in%20.NET%20Core%203.1" style="font-size: 0px; width:24px;height:24px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="reddit" title="Share on Reddit" class="synved-share-image synved-social-image synved-social-image-share" width="24" height="24" style="display: inline; width:24px;height:24px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.sswug.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/48x48/reddit.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-24 synved-social-resolution-single synved-social-provider-pinterest nolightbox" data-provider="pinterest" target="_blank" rel="nofollow" title="Pin it with Pinterest" href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fwww.sswug.org%2F%3Fp%3D275997&#038;media=&#038;description=Worker%20Service%20in%20.NET%20Core%203.1" style="font-size: 0px; width:24px;height:24px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="pinterest" title="Pin it with Pinterest" class="synved-share-image synved-social-image synved-social-image-share" width="24" height="24" style="display: inline; width:24px;height:24px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.sswug.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/48x48/pinterest.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-24 synved-social-resolution-single synved-social-provider-linkedin nolightbox" data-provider="linkedin" target="_blank" rel="nofollow" title="Share on Linkedin" href="http://www.linkedin.com/shareArticle?mini=true&#038;url=https%3A%2F%2Fwww.sswug.org%2F%3Fp%3D275997&#038;title=Worker%20Service%20in%20.NET%20Core%203.1" style="font-size: 0px; width:24px;height:24px;margin:0;margin-bottom:5px;margin-right:5px;"><img alt="linkedin" title="Share on Linkedin" class="synved-share-image synved-social-image synved-social-image-share" width="24" height="24" style="display: inline; width:24px;height:24px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.sswug.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/48x48/linkedin.png" /></a><a class="synved-social-button synved-social-button-share synved-social-size-24 synved-social-resolution-single synved-social-provider-mail nolightbox" data-provider="mail" rel="nofollow" title="Share by email" href="mailto:?subject=Worker%20Service%20in%20.NET%20Core%203.1&#038;body=Hey%20check%20this%20out:%20https%3A%2F%2Fwww.sswug.org%2F%3Fp%3D275997" style="font-size: 0px; width:24px;height:24px;margin:0;margin-bottom:5px;"><img alt="mail" title="Share by email" class="synved-share-image synved-social-image synved-social-image-share" width="24" height="24" style="display: inline; width:24px;height:24px; margin: 0; padding: 0; border: none; box-shadow: none;" src="https://www.sswug.org/wp-content/plugins/social-media-feather/synved-social/image/social/regular/48x48/mail.png" /></a><div class="clear"></div></div><footer class="entry-footer"><div class="tag_list">Tags: <a href="https://www.sswug.org/tag/development/" rel="tag">Development</a></div><div class="post_author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/a870a712779d9f71ceb4ccc58d3cc617?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a870a712779d9f71ceb4ccc58d3cc617?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><div class="author-description"> <span>Author: <a class="url fn n" href="https://www.sswug.org/author/sswugresearch/">SSWUG Research</a></span>SSWUG Research is the team that brings you SSWUG-based content and community links.  Have an idea?  Send us a note at sswugresearch@bitsonthewire.com - we'd love to hear from you.</div><div class="clear"></div></div></footer></article><div id="disqus_thread"></div> <script>var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"275997 https:\/\/www.sswug.org\/?p=275997","disqusShortname":"sswug","disqusTitle":"Worker Service in .NET Core 3.1","disqusUrl":"https:\/\/www.sswug.org\/sswugresearch\/community\/worker-service-in-net-core-3-1\/","postId":275997};
    var disqus_url = embedVars.disqusUrl;
var disqus_identifier = embedVars.disqusIdentifier;
var disqus_container_id = 'disqus_thread';
var disqus_shortname = embedVars.disqusShortname;
var disqus_title = embedVars.disqusTitle;
var disqus_config_custom = window.disqus_config;
var disqus_config = function () {
    /*
    All currently supported events:
    onReady: fires when everything is ready,
    onNewComment: fires when a new comment is posted,
    onIdentify: fires when user is authenticated
    */
    var dsqConfig = embedVars.disqusConfig;
    this.page.integration = dsqConfig.integration;
    this.page.remote_auth_s3 = dsqConfig.remote_auth_s3;
    this.page.api_key = dsqConfig.api_key;
    this.sso = dsqConfig.sso;
    this.language = dsqConfig.language;

    if (disqus_config_custom)
        disqus_config_custom.call(this);
};

(function() {
    var dsq = document.createElement('script');
    dsq.type = 'text/javascript';
    dsq.async = true;
    dsq.src = 'https://' + disqus_shortname + '.disqus.com/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(dsq);
})();</script> </div></main><section id="sidebar"><div id="login_logout-5" class="widget widget_login_logout"><ul class="wrap_login_logout"><li class="item_login"><a href="https://www.sswug.org/login/?redirect_to=%2F">Login</a></li></ul></div><div id="wpzoom-feature-posts-2" class="widget feature-posts"><h3 class="title">Recent Posts</h3><ul class="feature-posts-list"><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/understanding-bytecode-and-java-virtual-machines/">Understanding Bytecode and Java Virtual Machines</a></h3></div><span class="recent-date">16 seconds ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/sql-server-concepts/">SQL Server Concepts</a></h3></div><span class="recent-date">17 seconds ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/node-js-mysql-tutorial/">Node.js MySQL Tutorial</a></h3></div><span class="recent-date">18 seconds ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/">Worker Service in .NET Core 3.1</a></h3></div><span class="recent-date">18 seconds ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/exposing-a-custom-type-as-a-json-string-in-an-asp-net-core-api/">Exposing a custom type as a JSON string in an ASP.NET Core API</a></h3></div><span class="recent-date">19 seconds ago</span><div class="clear"></div></li></ul><div class="clear"></div></div></section><div class="clear"></div><div class="full-widget-area"><div class="widget carousel-slider" id="wpzoom-carousel-slider-6"><div id="loading-widget-wpzoom-carousel-slider-6-id"><div class="spinner"><div class="rect1"></div><div class="rect2"></div><div class="rect3"></div><div class="rect4"></div><div class="rect5"></div></div></div><div class="carousel_widget_wrapper" id="carousel_widget_wrapper-widget-wpzoom-carousel-slider-6-id"><div id="carousel-widget-wpzoom-carousel-slider-6-id"><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/understanding-bytecode-and-java-virtual-machines/" title="Understanding Bytecode and Java Virtual Machines">Understanding Bytecode and Java Virtual Machines</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/sql-server-concepts/" title="SQL Server Concepts">SQL Server Concepts</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/worker-service-in-net-core-3-1/" title="Worker Service in .NET Core 3.1">Worker Service in .NET Core 3.1</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/node-js-mysql-tutorial/" title="Node.js MySQL Tutorial">Node.js MySQL Tutorial</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/exposing-a-custom-type-as-a-json-string-in-an-asp-net-core-api/" title="Exposing a custom type as a JSON string in an ASP.NET Core API">Exposing a custom type as a JSON string in an ASP.NET Core API</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/how-to-list-and-download-the-contents-of-a-github-repo-in-c/" title="How to list and download the contents of a GitHub repo in C#">How to list and download the contents of a GitHub repo in C#</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/unauditable-select/" title="unauditable select">unauditable select</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/simple-performance-tuning-example/" title="Simple Performance Tuning Example">Simple Performance Tuning Example</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/oic-identity-propagation-in-structured-process/" title="OIC: Identity Propagation In Structured Process">OIC: Identity Propagation In Structured Process</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/announcing-two-new-db2-web-query-editions/" title="Announcing Two New Db2 Web Query Editions!">Announcing Two New Db2 Web Query Editions!</a></h3></div></div><div class="clear"></div></div> <script type="text/javascript">jQuery(function($) {

                var $c = $('#carousel-widget-wpzoom-carousel-slider-6-id');

                $c.imagesLoaded( function(){

                    $('#carousel_widget_wrapper-widget-wpzoom-carousel-slider-6-id').show();
                    $('#loading-widget-wpzoom-carousel-slider-6-id').hide();

                    $c.flickity({
                        autoPlay: false,
                        cellAlign: 'left',
                        percentPosition: true,
                        pageDots: false,
                        wrapAround: true,
                        imagesLoaded: true,
                        accessibility: false
                    });

                });

            });</script><div class="clear">&nbsp;</div></div></div><div class="clear"></div></div><div class="clear"></div><div id="footer"><div class="footer-logo"><h2><a href="https://www.sswug.org" title="SQL Server, Azure SQL Database, Amazon RDS &amp; AWS, Oracle and IBM Help">SSWUG.ORG</a></h2></div><div class="clear"></div><div class="footer-info"> <span class="copyright">Copyright &copy; 2020 SSWUG.ORG</span> <span class="designed">Designed by <a href="https://www.wpzoom.com/" rel="nofollow" target="_blank" title="WPZOOM WordPress Themes">WPZOOM</a></span></div><div class="clear"></div></div>  <script type="text/javascript">var Tawk_API=Tawk_API||{};
var Tawk_LoadStart=new Date();
(function(){
var s1=document.createElement("script"),s0=document.getElementsByTagName("script")[0];
s1.async=true;
s1.src='https://embed.tawk.to/5570d59958d482ac6c4ae1dc/default';
s1.charset='UTF-8';
s1.setAttribute('crossorigin','*');
s0.parentNode.insertBefore(s1,s0);
})();</script>  <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-31142-1', 'auto');
  ga('send', 'pageview');</script><script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script><script>(function($){$(document).ready(function(){});})(jQuery);</script><noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=252348685283892&ev=PageView&noscript=1" alt="facebook_pixel"></noscript> <noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=252348685283892&ev=GeneralEvent&noscript=1&cd[post_type]=post&cd[post_id]=275997&cd[content_name]=Worker+Service+in+.NET+Core+3.1&cd[categories]=Community&cd[tags]=Development" alt="facebook_pixel"></noscript> <script type="text/javascript">jQuery(document).ready( function() { jQuery.post( "https://www.sswug.org/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "689a551e3f", post_id : 275997 } ); } );</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.sswug.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var countVars = {"disqusShortname":"sswug"};</script> <script type='text/javascript'>var themeMyLogin = {"action":"","errors":[]};</script> <script type='text/javascript'>var zoomOptions = [];</script> <script type='text/javascript'>var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};</script> <div id="cookie-notice" role="banner" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(0,0,0,1);"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button">Ok</a></span><a href="javascript:void(0);" id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon"></a></div></div></body></html>