<!DOCTYPE html><html lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link rel="profile" href="http://gmpg.org/xfn/11"><link rel="pingback" href="https://www.sswug.org/xmlrpc.php"><link media="all" href="https://www.sswug.org/wp-content/cache/autoptimize/css/autoptimize_ee4ef62f6706d7b4319bfd00a1df9468.css" rel="stylesheet" /><link media="screen" href="https://www.sswug.org/wp-content/cache/autoptimize/css/autoptimize_67dcd357d1d4674a59afb5128994bd43.css" rel="stylesheet" /><style media="print">@media print{.pmpro_a-print{display:none;position:absolute;left:-9999px}}</style><title>Part II: Overview of B- Tree and B+ Tree - SSWUG.ORG</title><meta name="robots" content="index, follow" /><meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" /><link rel="canonical" href="https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/" /><meta property="og:locale" content="en_US" /><meta property="og:type" content="article" /><meta property="og:title" content="Part II: Overview of B- Tree and B+ Tree - SSWUG.ORG" /><meta property="og:description" content="Introduction to B+ Tree The drawback of the B tree used for indexing is that it stores a data pointer (a pointer to a block of a disk file with a key value) that matches a given key value, along with that key value in the B tree node. This technique significantly reduces the number of entries that can be... [&hellip;]" /><meta property="og:url" content="https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/" /><meta property="og:site_name" content="SSWUG.ORG" /><meta property="article:publisher" content="https://www.facebook.com/SSWUG" /><meta property="article:published_time" content="2020-08-10T07:00:00+00:00" /><meta property="article:modified_time" content="2020-06-11T17:31:11+00:00" /><meta name="twitter:card" content="summary" /><meta name="twitter:creator" content="@SSWUGORG" /><meta name="twitter:site" content="@SSWUGORG" /> <script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://www.sswug.org/#website","url":"https://www.sswug.org/","name":"SSWUG.ORG","description":"SQL Server, Azure SQL Database, Amazon RDS &amp; AWS, Oracle and IBM Help","potentialAction":[{"@type":"SearchAction","target":"https://www.sswug.org/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"WebPage","@id":"https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/#webpage","url":"https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/","name":"Part II: Overview of B- Tree and B+ Tree - SSWUG.ORG","isPartOf":{"@id":"https://www.sswug.org/#website"},"datePublished":"2020-08-10T07:00:00+00:00","dateModified":"2020-06-11T17:31:11+00:00","author":{"@id":"https://www.sswug.org/#/schema/person/2d84ac5f21eafe11ed9f6ec83e86731b"},"breadcrumb":{"@id":"https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/#breadcrumb"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/"]}]},{"@type":"BreadcrumbList","@id":"https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/#breadcrumb","itemListElement":[{"@type":"ListItem","position":1,"item":{"@type":"WebPage","@id":"https://www.sswug.org/","url":"https://www.sswug.org/","name":"Home"}},{"@type":"ListItem","position":2,"item":{"@type":"WebPage","@id":"https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/","url":"https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/","name":"Part II: Overview of B- Tree and B+ Tree"}}]},{"@type":["Person"],"@id":"https://www.sswug.org/#/schema/person/2d84ac5f21eafe11ed9f6ec83e86731b","name":"Sunny Singh","image":{"@type":"ImageObject","@id":"https://www.sswug.org/#personlogo","inLanguage":"en-US","url":"https://secure.gravatar.com/avatar/0d34bdfdd8f2c4220fa9f03b29ade5dc?s=96&d=mm&r=g","caption":"Sunny Singh"},"description":"Sunny is a regular contributor to SSWUG.ORG."}]}</script>  <script type='text/javascript'>console.log('PixelYourSite Free version 7.1.7');</script> <link rel='dns-prefetch' href='//ssl.p.jwpcdn.com' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="SSWUG.ORG &raquo; Feed" href="https://www.sswug.org/feed/" /><link rel="alternate" type="application/rss+xml" title="SSWUG.ORG &raquo; Comments Feed" href="https://www.sswug.org/comments/feed/" /><link rel="alternate" type="text/calendar" title="SSWUG.ORG &raquo; iCal Feed" href="https://www.sswug.org/events/?ical=1" /><link rel="alternate" type="application/rss+xml" title="SSWUG.ORG &raquo; Part II: Overview of B- Tree and B+ Tree Comments Feed" href="https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/feed/" /> <script type="text/javascript">window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.sswug.org\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.3.4"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='dashicons-css'  href='https://www.sswug.org/wp-includes/css/dashicons.min.css?ver=5.3.4' type='text/css' media='all' /><style id='wp-image-borders-styles-inline-css' type='text/css'>.wp-image-borders .alignright,
		.wp-image-borders .alignleft,
		.wp-image-borders .aligncenter,
		.wp-image-borders .alignnone,
		.wp-image-borders .size-auto,
		.wp-image-borders .size-full,
		.wp-image-borders .size-large,
		.wp-image-borders .size-medium,
		.wp-image-borders .size-thumbnail,
		.wp-image-borders .alignright img,
		.wp-image-borders .alignleft img,
		.wp-image-borders .aligncenter img,
		.wp-image-borders .alignnone img,
		.wp-image-borders .size-auto img,
		.wp-image-borders .size-full img,
		.wp-image-borders .size-large img,
		.wp-image-borders .size-medium img,
		.wp-image-borders .size-thumbnail img {
	   border-style: solid !important;
	   border-width: 1px !important;
	   border-radius: 1px !important;
	   border-color: #383838 !important;
	   -moz-box-shadow: 0px 0px 0px 0px #afafaf !important;
	   -webkit-box-shadow: 0px 0px 0px 0px #afafaf !important;
	   box-shadow: 0px 0px 0px 0px #afafaf !important;
   }</style><link rel='stylesheet' id='tribune-google-fonts-css'  href='//fonts.googleapis.com/css?family=Merriweather%3Aregular%2C700%2C700i%2Citalic%7CPlayfair+Display%3Aregular%2C700%7CMontserrat%3Aregular%2C700%7CRoboto+Condensed%3Aregular%2C700&#038;ver=5.3.4' type='text/css' media='all' /><link rel='stylesheet' id='tribune-google-font-default-css'  href='//fonts.googleapis.com/css?family=Montserrat%3A400%2C700%7CPlayfair+Display%3A400%2C700%7CRoboto+Condensed%3A400%2C700%7CMerriweather%3A400%2C700%2C900%2C400italic%2C700italic%2C900italic&#038;subset=latin%2Cgreek%2Ccyrillic&#038;ver=5.3.4' type='text/css' media='all' /> <script type='text/javascript'>var cnArgs = {"ajaxUrl":"https:\/\/www.sswug.org\/wp-admin\/admin-ajax.php","nonce":"dab495c034","hideEffect":"fade","position":"bottom","onScroll":"0","onScrollOffset":"100","onClick":"0","cookieName":"cookie_notice_accepted","cookieTime":"2592000","cookieTimeRejected":"2592000","cookiePath":"\/","cookieDomain":"","redirection":"0","cache":"0","refuse":"0","revokeCookies":"0","revokeCookiesOpt":"automatic","secure":"1","coronabarActive":"0"};</script> <script type='text/javascript' src='https://ssl.p.jwpcdn.com/6/12/jwplayer.js?ver=5.3.4'></script> <script type='text/javascript'>var pysOptions = {"staticEvents":{"facebook":{"PageView":[{"params":[],"delay":0,"ids":[]}],"GeneralEvent":[{"params":{"post_type":"post","post_id":"275496","content_name":"Part II: Overview of B- Tree and B+ Tree","categories":"Pro Members, SQL Server, Standard Members","tags":""},"delay":0,"ids":[]}]}},"dynamicEventsParams":[],"dynamicEventsTriggers":[],"facebook":{"pixelIds":["252348685283892"],"advancedMatching":[],"removeMetadata":false,"contentParams":{"post_type":"post","post_id":275496,"content_name":"Part II: Overview of B- Tree and B+ Tree","categories":"Pro Members, SQL Server, Standard Members","tags":""},"commentEventEnabled":true,"wooVariableAsSimple":false,"downloadEnabled":true,"formEventEnabled":true},"debug":"","siteUrl":"https:\/\/www.sswug.org","ajaxUrl":"https:\/\/www.sswug.org\/wp-admin\/admin-ajax.php","commonEventParams":{"domain":"\/www.sswug.org","user_roles":"guest","plugin":"PixelYourSite"},"commentEventEnabled":"1","downloadEventEnabled":"1","downloadExtensions":["doc","exe","js","pdf","ppt","tgz","zip","xls"],"formEventEnabled":"1","gdpr":{"ajax_enabled":false,"all_disabled_by_api":false,"facebook_disabled_by_api":false,"analytics_disabled_by_api":false,"google_ads_disabled_by_api":false,"pinterest_disabled_by_api":false,"bing_disabled_by_api":false,"facebook_prior_consent_enabled":false,"analytics_prior_consent_enabled":true,"google_ads_prior_consent_enabled":null,"pinterest_prior_consent_enabled":true,"bing_prior_consent_enabled":true,"cookiebot_integration_enabled":false,"cookiebot_facebook_consent_category":"marketing","cookiebot_analytics_consent_category":"statistics","cookiebot_google_ads_consent_category":null,"cookiebot_pinterest_consent_category":"marketing","cookiebot_bing_consent_category":"marketing","ginger_integration_enabled":false,"cookie_notice_integration_enabled":false,"cookie_law_info_integration_enabled":false},"woo":{"enabled":false,"addToCartOnButtonEnabled":false,"addToCartOnButtonValueEnabled":false,"addToCartOnButtonValueOption":"price","removeFromCartEnabled":true,"removeFromCartSelector":".cart .product-remove .remove"},"edd":{"enabled":false,"addToCartOnButtonEnabled":false,"addToCartOnButtonValueEnabled":false,"addToCartOnButtonValueOption":"price","removeFromCartEnabled":true}};</script> <link rel='https://api.w.org/' href='https://www.sswug.org/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.sswug.org/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.sswug.org/wp-includes/wlwmanifest.xml" /><link rel='shortlink' href='https://www.sswug.org/?p=275496' /><link rel="alternate" type="application/json+oembed" href="https://www.sswug.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sswug.org%2Fsunnysingh%2Fsql-server%2Fpart-ii-overview-of-b-tree-and-b-tree%2F" /><link rel="alternate" type="text/xml+oembed" href="https://www.sswug.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.sswug.org%2Fsunnysingh%2Fsql-server%2Fpart-ii-overview-of-b-tree-and-b-tree%2F&#038;format=xml" /> <script type="text/javascript">jwplayer.key='wzJCN7+7VY5JsZZ8qAwstqzKkDxqb5Xtdk+zp8Q1cgk=';jwplayer.defaults = { "ph": 2 };</script> <script type="text/javascript">if (typeof(jwp6AddLoadEvent) == 'undefined') {
                function jwp6AddLoadEvent(func) {
                    var oldonload = window.onload;
                    if (typeof window.onload != 'function') {
                        window.onload = func;
                    } else {
                        window.onload = function() {
                            if (oldonload) {
                                oldonload();
                            }
                            func();
                        }
                    }
                }
            }</script> <meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://www.sswug.org"><link rel="https://theeventscalendar.com/" href="https://www.sswug.org/wp-json/tribe/events/v1/" /><meta name="generator" content="Tribune 4.2.2" /><meta name="generator" content="WPZOOM Framework 1.9.0" /> <script type="text/javascript">document.write('<style type="text/css">.tabber{display:none;}</style>');</script> <style type="text/css" id="tribune-custom-css">.navbar-brand .tagline{display:none;}.sb-search{display:none;}.main-navbar{background:#3d3d3d;}.main-navbar #navbar-main a:hover{color:#f75636;}#footer{background-color:#0a0000;}</style><style type="text/css"></style><style type="text/css">.synved-social-resolution-single {
display: inline-block;
}
.synved-social-resolution-normal {
display: inline-block;
}
.synved-social-resolution-hidef {
display: none;
}

@media only screen and (min--moz-device-pixel-ratio: 2),
only screen and (-o-min-device-pixel-ratio: 2/1),
only screen and (-webkit-min-device-pixel-ratio: 2),
only screen and (min-device-pixel-ratio: 2),
only screen and (min-resolution: 2dppx),
only screen and (min-resolution: 192dpi) {
	.synved-social-resolution-normal {
	display: none;
	}
	.synved-social-resolution-hidef {
	display: inline-block;
	}
}</style><style type="text/css" id="custom-background-css">body.custom-background { background-color: #d6d6d6; }</style> <script src="https://www.sswug.org/wp-content/cache/autoptimize/js/autoptimize_9d2d7f9bd4c404a60949687290537c14.js"></script></head><body class="post-template-default single single-post postid-275496 single-format-standard custom-background wp-custom-logo cookies-not-set pmpro-body-level-required pmpro-body-level-9 pmpro-body-level-8 pmpro-body-level-1 tribe-no-js elementor-default"><div class="site-wrap"><div class="page-wrap"><header id="header"><nav class="navbar" role="navigation"><nav class="top-navbar" role="navigation"><div class="header_social"><div id="search-5" class="widget widget_search"><form method="get" id="searchform" action="https://www.sswug.org/"> <input type="search" class="sb-search-input" placeholder="Enter your keywords..."  name="s" id="s" /> <input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" /> <span class="sb-icon-search"></span></form><div class="clear"></div></div></div><div class="navbar-header"> <a class="navbar-toggle" href="#menu-top-slide"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </a><div id="menu-top-slide" class="menu-member-options-menu-container"><ul id="menu-member-options-menu" class="menu"><li id="menu-item-252522" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252522"><a href="/wp-login.php">Login</a></li><li id="menu-item-143422" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-143422"><a href="https://www.sswug.org/membership-account/">Join / Your Account</a><ul class="sub-menu"><li id="menu-item-252523" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252523"><a href="http://bitonthewire.wpengine.com/wp-login.php">Login</a></li><li id="menu-item-143424" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143424"><a href="/membership-options-19/">Register</a></li><li id="menu-item-256230" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256230"><a href="/membership-options-19/">Membership Levels</a></li><li id="menu-item-236145" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236145"><a href="/membership-account/">My Membership</a></li></ul></li><li id="menu-item-143440" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143440"><a href="https://www.sswug.org/about-sswug-org/">Why Join?</a></li><li id="menu-item-143437" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143437"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li></ul></div></div><div id="navbar-top"><div class="menu-member-options-menu-container"><ul id="menu-member-options-menu-1" class="nav navbar-nav dropdown sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252522"><a href="/wp-login.php">Login</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-143422"><a href="https://www.sswug.org/membership-account/">Join / Your Account</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252523"><a href="http://bitonthewire.wpengine.com/wp-login.php">Login</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143424"><a href="/membership-options-19/">Register</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-256230"><a href="/membership-options-19/">Membership Levels</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236145"><a href="/membership-account/">My Membership</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143440"><a href="https://www.sswug.org/about-sswug-org/">Why Join?</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143437"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li></ul></div></div></nav><div class="clear"></div></nav><div id="header-inner"><div class="navbar-brand left-align"> <a href="https://www.sswug.org/" class="custom-logo-link" rel="home" itemprop="url"><img width="600" height="184" src="https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-600x184.png" class="custom-logo" alt="SSWUG.ORG" itemprop="logo" srcset="https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo.png 600w, https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-300x92.png 300w, https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-179x55.png 179w, https://s3.amazonaws.com/sswugwp/wp-content/uploads/2019/12/12131233/cropped-SSWUGorg-Logo-431x132.png 431w" sizes="(max-width: 600px) 100vw, 600px" /></a> <span class="tagline">SQL Server, Azure SQL Database, Amazon RDS &amp; AWS, Oracle and IBM Help</span> <span class="header_date">Monday, August 10, 2020</span></div><div id="head_banner"> <span style="font-size:12px;"><b>An online community of DBAs, developers and data intelligence builders,</b> with videos, articles, resources and online<Br> events for members and non-members.    <a href="/membership-options-19/"><b>Find out more</a> >></b></span></div><div class="clear"></div></div><nav class="navbar" role="navigation"><nav class="main-navbar" role="navigation"><div id="sb-search" class="sb-search"><form method="get" id="searchform" action="https://www.sswug.org/"> <input type="search" class="sb-search-input" placeholder="Enter your keywords..."  name="s" id="s" /> <input type="submit" id="searchsubmit" class="sb-search-submit" value="Search" /> <span class="sb-icon-search"></span></form></div><div class="navbar-header"> <a class="navbar-toggle" href="#menu-main-slide"> <span class="toggle-bars"> <span class="icon-bar"></span> <span class="icon-bar"></span> <span class="icon-bar"></span> </span> <span class="toggle-text">Menu</span> </a><div id="menu-main-slide" class="menu-main-menu-container"><ul id="menu-main-menu" class="menu"><li id="menu-item-143371" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143371"><a href="/">Home</a></li><li id="menu-item-2435" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2435"><a>Content Areas</a><ul class="sub-menu"><li id="menu-item-72833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72833"><a href="/">Regular Contributors</a><ul class="sub-menu"><li id="menu-item-72838" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72838"><a href="/author/alexanderchigrik/">Alexander Chigrik</a></li><li id="menu-item-72836" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72836"><a href="/?s=kevin+kline">Kevin Kline</a></li><li id="menu-item-72834" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72834"><a href="/author/laurarose/">Laura Rose</a></li><li id="menu-item-72835" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72835"><a href="/author/swynk/">Stephen Wynkoop</a></li></ul></li><li id="menu-item-2433" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2433"><a href="https://www.sswug.org/category/development/">Development</a></li><li id="menu-item-252514" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252514"><a href="/tag/IBM">IBM</a></li><li id="menu-item-252515" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252515"><a href="/tag/json-java-xml/">JSON/JAVA/XML</a></li><li id="menu-item-252516" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252516"><a href="/tag/open-source">Open Source</a></li><li id="menu-item-252517" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252517"><a href="/tag/SQL-Server">SQL Server</a></li><li id="menu-item-252518" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252518"><a href="/tag/oracle">Oracle</a></li><li id="menu-item-252519" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252519"><a href="/tag/sharepoint-bi/">Sharepoint/BI</a></li><li id="menu-item-251907" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251907"><a href="/?s=(script%20library)">Script Library</a></li></ul></li><li id="menu-item-143494" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143494"><a>Video</a><ul class="sub-menu"><li id="menu-item-236121" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236121"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li id="menu-item-72840" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72840"><a href="/?s=sswugtv%20kevin%20kline">Kevin Kline Briefings</a></li><li id="menu-item-72839" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72839"><a href="/?s=laura+rose">Laura Rose Coaching Series</a></li><li id="menu-item-143495" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143495"><a href="/?s=sswugtv">SSWUGtv Shows</a></li></ul></li><li id="menu-item-143456" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143456"><a href="/events/">Online Events</a><ul class="sub-menu"><li id="menu-item-236119" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236119"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li id="menu-item-236120" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236120"><a href="/events/">Upcoming Events</a></li></ul></li><li id="menu-item-2430" class="b menu-item menu-item-type-custom menu-item-object-custom menu-item-2430"><a target="_blank" rel="noopener noreferrer" href="http://careers.sswug.org">Job Board</a></li><li id="menu-item-244968" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-244968"><a href="https://www.sswug.org/what-is-a-pro-membership/">Pro Members</a><ul class="sub-menu"><li id="menu-item-244971" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244971"><a href="https://www.sswug.org/what-is-a-pro-membership/">About Pro Membership</a></li><li id="menu-item-244970" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244970"><a href="https://www.sswug.org/video-categories-and-options/">Video Categories</a></li><li id="menu-item-244972" class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-244972"><a href="https://www.sswug.org/tag/pro-video/">Video Selections</a></li><li id="menu-item-244988" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244988"><a href="https://www.sswug.org/category/class-info/">Online Classes</a></li></ul></li><li id="menu-item-71898" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-71898"><a href="/">About SSWUG.org</a><ul class="sub-menu"><li id="menu-item-71899" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71899"><a href="https://www.sswug.org/about-sswug-org/">About SSWUG.org</a></li><li id="menu-item-72821" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-72821"><a href="https://www.sswug.org/submit-an-article-to-sswug-org/">Write for SSWUG</a><ul class="sub-menu"><li id="menu-item-72831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72831"><a href="https://www.sswug.org/about-writing-for-sswug/">About Writing for SSWUG</a></li></ul></li><li id="menu-item-72828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72828"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li><li id="menu-item-143506" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143506"><a href="https://www.sswug.org/privacy-statement-for-sswug-orgthe-sql-server-worldwide-users-group/">Privacy Statement</a></li><li id="menu-item-143501" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143501"><a href="https://www.sswug.org/terms-of-service-2/">Terms of Service.</a></li><li id="menu-item-72825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72825"><a href="https://www.sswug.org/advertising-options/">Advertising Options</a></li></ul></li></ul></div></div><div id="navbar-main"><div class="menu-main-menu-container"><ul id="menu-main-menu-1" class="nav navbar-nav dropdown sf-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143371"><a href="/">Home</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2435"><a>Content Areas</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-72833"><a href="/">Regular Contributors</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72838"><a href="/author/alexanderchigrik/">Alexander Chigrik</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72836"><a href="/?s=kevin+kline">Kevin Kline</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72834"><a href="/author/laurarose/">Laura Rose</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72835"><a href="/author/swynk/">Stephen Wynkoop</a></li></ul></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-2433"><a href="https://www.sswug.org/category/development/">Development</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252514"><a href="/tag/IBM">IBM</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252515"><a href="/tag/json-java-xml/">JSON/JAVA/XML</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252516"><a href="/tag/open-source">Open Source</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252517"><a href="/tag/SQL-Server">SQL Server</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252518"><a href="/tag/oracle">Oracle</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-252519"><a href="/tag/sharepoint-bi/">Sharepoint/BI</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-251907"><a href="/?s=(script%20library)">Script Library</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143494"><a>Video</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236121"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72840"><a href="/?s=sswugtv%20kevin%20kline">Kevin Kline Briefings</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-72839"><a href="/?s=laura+rose">Laura Rose Coaching Series</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-143495"><a href="/?s=sswugtv">SSWUGtv Shows</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-143456"><a href="/events/">Online Events</a><ul class="sub-menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236119"><a href="/timr/uncategorized/course-titles/">SSWUG.org Classes</a></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-236120"><a href="/events/">Upcoming Events</a></li></ul></li><li class="b menu-item menu-item-type-custom menu-item-object-custom menu-item-2430"><a target="_blank" rel="noopener noreferrer" href="http://careers.sswug.org">Job Board</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-244968"><a href="https://www.sswug.org/what-is-a-pro-membership/">Pro Members</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244971"><a href="https://www.sswug.org/what-is-a-pro-membership/">About Pro Membership</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-244970"><a href="https://www.sswug.org/video-categories-and-options/">Video Categories</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-post_tag menu-item-244972"><a href="https://www.sswug.org/tag/pro-video/">Video Selections</a></li><li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-244988"><a href="https://www.sswug.org/category/class-info/">Online Classes</a></li></ul></li><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-71898"><a href="/">About SSWUG.org</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-71899"><a href="https://www.sswug.org/about-sswug-org/">About SSWUG.org</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-72821"><a href="https://www.sswug.org/submit-an-article-to-sswug-org/">Write for SSWUG</a><ul class="sub-menu"><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72831"><a href="https://www.sswug.org/about-writing-for-sswug/">About Writing for SSWUG</a></li></ul></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72828"><a href="https://www.sswug.org/contact-us/">Contact Us</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143506"><a href="https://www.sswug.org/privacy-statement-for-sswug-orgthe-sql-server-worldwide-users-group/">Privacy Statement</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-143501"><a href="https://www.sswug.org/terms-of-service-2/">Terms of Service.</a></li><li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-72825"><a href="https://www.sswug.org/advertising-options/">Advertising Options</a></li></ul></li></ul></div></div><div class="clear"></div></nav></nav><div class="clear"></div></header><main id="main" role="main"><div class="content-area"><article id="post-275496" class="post-275496 post type-post status-publish format-standard category-pro-members category-sql-server category-std-members pmpro-level-required pmpro-level-9 pmpro-level-8 pmpro-level-1 pmpro-no-access"><header class="entry-header"> <span class="cat-links"><a href="https://www.sswug.org/category/pro-members/" rel="category tag">Pro Members</a>, <a href="https://www.sswug.org/category/sql-server/" rel="category tag">SQL Server</a>, <a href="https://www.sswug.org/category/std-members/" rel="category tag">Standard Members</a></span><h1 class="entry-title">Part II: Overview of B- Tree and B+ Tree</h1><div class="post-meta"> <span class="entry-author vcard author">by <a class="url fn n" href="https://www.sswug.org/author/sunnysingh/">Sunny Singh</a></span></div></header><div class="clear"></div><div class="entry-content"><p>Introduction to B+ Tree The drawback of the B tree used for indexing is that it stores a data pointer (a pointer to a block of a disk file with a key value) that matches a given key value, along with that key value in the B tree node. This technique significantly reduces the number of entries that can be&#8230;...</p><div class="pmpro_content_message">This content is for Pro, Pro Member, Pro Member Annual - Fall Sale, Pro Member Monthly - Fall Sale, Standard, Standard Member, Standard Member Annual - Fall Sale, and Standard Member Monthly - Fall Sale members only.<br /><a href="http://www.sswug.org/wp-login.php">Log In</a> <a href="http://www.sswug.org/wp-login.php?action=register">Register</a></div><div class="clear"></div></div><footer class="entry-footer"><div class="post_author vcard"> <img alt='' src='https://secure.gravatar.com/avatar/0d34bdfdd8f2c4220fa9f03b29ade5dc?s=70&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/0d34bdfdd8f2c4220fa9f03b29ade5dc?s=140&#038;d=mm&#038;r=g 2x' class='avatar avatar-70 photo' height='70' width='70' /><div class="author-description"> <span>Author: <a class="url fn n" href="https://www.sswug.org/author/sunnysingh/">Sunny Singh</a></span>Sunny is a regular contributor to SSWUG.ORG.</div><div class="clear"></div></div></footer></article><div id="comments"><p class="nocomments">Comments are closed.</p></div></div></main><section id="sidebar"><div id="login_logout-5" class="widget widget_login_logout"><ul class="wrap_login_logout"><li class="item_login"><a href="https://www.sswug.org/login/?redirect_to=%2F">Login</a></li></ul></div><div id="wpzoom-feature-posts-2" class="widget feature-posts"><h3 class="title">Recent Posts</h3><ul class="feature-posts-list"><li><div class="recent-title"><h3><a href="https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/">Part II: Overview of B- Tree and B+ Tree</a></h3></div><span class="recent-date">17 mins ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/laurarose/sql-server/is-it-undermining-or-rude-to-email-the-boss-to-ask-him-to-get-his-act-together/">Is it undermining or rude to email the boss to ask him to get his act together?</a></h3></div><span class="recent-date">3 days ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/getting-started-with-deep-learning-in-your-browser-using-tensorflow-js/">Getting Started With Deep Learning in Your Browser Using TensorFlow.js</a></h3></div><span class="recent-date">5 days ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/sql-server-collation-overview-and-examples/">SQL Server Collation Overview and Examples</a></h3></div><span class="recent-date">5 days ago</span><div class="clear"></div></li><li><div class="recent-title"><h3><a href="https://www.sswug.org/sswugresearch/community/mysql-escaping-on-the-client-side-with-go/">MySQL Escaping on the Client-Side With Go</a></h3></div><span class="recent-date">5 days ago</span><div class="clear"></div></li></ul><div class="clear"></div></div></section><div class="clear"></div><div class="full-widget-area"><div class="widget carousel-slider" id="wpzoom-carousel-slider-6"><div id="loading-widget-wpzoom-carousel-slider-6-id"><div class="spinner"><div class="rect1"></div><div class="rect2"></div><div class="rect3"></div><div class="rect4"></div><div class="rect5"></div></div></div><div class="carousel_widget_wrapper" id="carousel_widget_wrapper-widget-wpzoom-carousel-slider-6-id"><div id="carousel-widget-wpzoom-carousel-slider-6-id"><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/pro-members/" rel="category tag">Pro Members</a> / <a href="https://www.sswug.org/category/sql-server/" rel="category tag">SQL Server</a> / <a href="https://www.sswug.org/category/std-members/" rel="category tag">Standard Members</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sunnysingh/sql-server/part-ii-overview-of-b-tree-and-b-tree/" title="Part II: Overview of B- Tree and B+ Tree">Part II: Overview of B- Tree and B+ Tree</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/pro-members/" rel="category tag">Pro Members</a> / <a href="https://www.sswug.org/category/sql-server/" rel="category tag">SQL Server</a> / <a href="https://www.sswug.org/category/std-members/" rel="category tag">Standard Members</a></span><h3 class="entry-title"><a href="https://www.sswug.org/laurarose/sql-server/is-it-undermining-or-rude-to-email-the-boss-to-ask-him-to-get-his-act-together/" title="Is it undermining or rude to email the boss to ask him to get his act together?">Is it undermining or rude to email the boss to ask him to get his act together?</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/getting-started-with-deep-learning-in-your-browser-using-tensorflow-js/" title="Getting Started With Deep Learning in Your Browser Using TensorFlow.js">Getting Started With Deep Learning in Your Browser Using TensorFlow.js</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/sql-server-collation-overview-and-examples/" title="SQL Server Collation Overview and Examples">SQL Server Collation Overview and Examples</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/mysql-escaping-on-the-client-side-with-go/" title="MySQL Escaping on the Client-Side With Go">MySQL Escaping on the Client-Side With Go</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/vs-code-gets-new-python-language-server-named-after-monty-python-character/" title="VS Code Gets New Python Language Server, Named After Monty Python Character">VS Code Gets New Python Language Server, Named After Monty Python Character</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/how-hello-world-changed-top-level-statements-and-functions-c-9/" title="How Hello World! changed – top level statements and functions (C# 9)">How Hello World! changed – top level statements and functions (C# 9)</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/upgrading-the-node-image-of-an-azure-kubernetes-service-cluster/" title="Upgrading the node image of an Azure Kubernetes Service cluster">Upgrading the node image of an Azure Kubernetes Service cluster</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/pl-sql-generator-for-cfbf-files/" title="PL/SQL Generator for CFBF files">PL/SQL Generator for CFBF files</a></h3></div><div class="item"><span class="cat-links"><a href="https://www.sswug.org/category/community/" rel="category tag">Community</a></span><h3 class="entry-title"><a href="https://www.sswug.org/sswugresearch/community/oracle-19c-automatic-indexing-common-index-creation-trap-rat-trap/" title="Oracle 19c Automatic Indexing: Common Index Creation Trap (Rat Trap)">Oracle 19c Automatic Indexing: Common Index Creation Trap (Rat Trap)</a></h3></div></div><div class="clear"></div></div> <script type="text/javascript">jQuery(function($) {

                var $c = $('#carousel-widget-wpzoom-carousel-slider-6-id');

                $c.imagesLoaded( function(){

                    $('#carousel_widget_wrapper-widget-wpzoom-carousel-slider-6-id').show();
                    $('#loading-widget-wpzoom-carousel-slider-6-id').hide();

                    $c.flickity({
                        autoPlay: false,
                        cellAlign: 'left',
                        percentPosition: true,
                        pageDots: false,
                        wrapAround: true,
                        imagesLoaded: true,
                        accessibility: false
                    });

                });

            });</script><div class="clear">&nbsp;</div></div></div><div class="clear"></div></div><div class="clear"></div><div id="footer"><div class="footer-logo"><h2><a href="https://www.sswug.org" title="SQL Server, Azure SQL Database, Amazon RDS &amp; AWS, Oracle and IBM Help">SSWUG.ORG</a></h2></div><div class="clear"></div><div class="footer-info"> <span class="copyright">Copyright &copy; 2020 SSWUG.ORG</span> <span class="designed">Designed by <a href="https://www.wpzoom.com/" rel="nofollow" target="_blank" title="WPZOOM WordPress Themes">WPZOOM</a></span></div><div class="clear"></div></div>  <script type="text/javascript">var Tawk_API=Tawk_API||{};
var Tawk_LoadStart=new Date();
(function(){
var s1=document.createElement("script"),s0=document.getElementsByTagName("script")[0];
s1.async=true;
s1.src='https://embed.tawk.to/5570d59958d482ac6c4ae1dc/default';
s1.charset='UTF-8';
s1.setAttribute('crossorigin','*');
s0.parentNode.insertBefore(s1,s0);
})();</script>  <script>( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );</script> <script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-31142-1', 'auto');
  ga('send', 'pageview');</script><script>var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};</script><script>(function($){$(document).ready(function(){});})(jQuery);</script><noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=252348685283892&ev=PageView&noscript=1" alt="facebook_pixel"></noscript> <noscript><img height="1" width="1" style="display: none;" src="https://www.facebook.com/tr?id=252348685283892&ev=GeneralEvent&noscript=1&cd[post_type]=post&cd[post_id]=275496&cd[content_name]=Part+II%3A+Overview+of+B-+Tree+and+B%2B+Tree&cd[categories]=Pro+Members%2C+SQL+Server%2C+Standard+Members&cd[tags]" alt="facebook_pixel"></noscript> <script type="text/javascript">jQuery(document).ready( function() { jQuery.post( "https://www.sswug.org/wp-admin/admin-ajax.php", { action : "entry_views", _ajax_nonce : "f9eb466f16", post_id : 275496 } ); } );</script> <script type='text/javascript'>var wpcf7 = {"apiSettings":{"root":"https:\/\/www.sswug.org\/wp-json\/contact-form-7\/v1","namespace":"contact-form-7\/v1"}};</script> <script type='text/javascript'>var countVars = {"disqusShortname":"sswug"};</script> <script type='text/javascript'>var themeMyLogin = {"action":"","errors":[]};</script> <script type='text/javascript'>var zoomOptions = [];</script> <script type='text/javascript'>var newsletter = {"messages":{"email_error":"The email is not correct","name_error":"The name is not correct","surname_error":"The last name is not correct","profile_error":"A mandatory field is not filled in","privacy_error":"You must accept the privacy statement"},"profile_max":"20"};</script> <div id="cookie-notice" role="banner" class="cookie-notice-hidden cookie-revoke-hidden cn-position-bottom" aria-label="Cookie Notice" style="background-color: rgba(0,0,0,1);"><div class="cookie-notice-container" style="color: #fff;"><span id="cn-notice-text" class="cn-text-container">We use cookies to ensure that we give you the best experience on our website. If you continue to use this site we will assume that you are happy with it.</span><span id="cn-notice-buttons" class="cn-buttons-container"><a href="#" id="cn-accept-cookie" data-cookie-set="accept" class="cn-set-cookie cn-button bootstrap button">Ok</a></span><a href="javascript:void(0);" id="cn-close-notice" data-cookie-set="accept" class="cn-close-icon"></a></div></div></body></html>